3v4l.org

run code in 300+ PHP versions simultaneously
<?php function __autoload($class) { echo $class; } method_exists('../../../../../../../etc/passwd' . "\x00", 'a');
based on 06fvS
Output for 8.0.0
Fatal error: __autoload() is no longer supported, use spl_autoload_register() instead in /in/NU40c on line 3
Process exited with code 255.
Output for 7.2.0 - 7.2.33, 7.3.16 - 7.3.24, 7.4.0 - 7.4.13
Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in /in/NU40c on line 3
Output for 4.3.0 - 4.3.11, 4.4.0 - 4.4.9, 5.0.0 - 5.0.5, 5.4.24 - 5.4.45, 5.5.8 - 5.5.38, 5.6.0 - 5.6.28, 7.0.0 - 7.0.20, 7.1.0 - 7.1.20
Output for 5.1.0 - 5.1.6, 5.2.0 - 5.2.17, 5.3.0 - 5.3.29, 5.4.0 - 5.4.23, 5.5.0 - 5.5.7
../../../../../../../etc/passwd