3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php $a = ['A', 'Abc', 'def']; var_dump(array_combine(array_walk($a, 'strtolower'), $a));
Output for 7.3.0alpha1 - 7.3.0rc3
Warning: strtolower() expects exactly 1 parameter, 2 given in /in/LgplG on line 5 Warning: strtolower() expects exactly 1 parameter, 2 given in /in/LgplG on line 5 Warning: strtolower() expects exactly 1 parameter, 2 given in /in/LgplG on line 5 Warning: array_combine() expects parameter 1 to be array, bool given in /in/LgplG on line 5 NULL
Output for 5.6.0 - 5.6.30, 7.0.0 - 7.2.6
Warning: strtolower() expects exactly 1 parameter, 2 given in /in/LgplG on line 5 Warning: strtolower() expects exactly 1 parameter, 2 given in /in/LgplG on line 5 Warning: strtolower() expects exactly 1 parameter, 2 given in /in/LgplG on line 5 Warning: array_combine() expects parameter 1 to be array, boolean given in /in/LgplG on line 5 NULL
Output for hhvm-3.15.4
Warning: strtolower() expects exactly 1 parameter, 2 given in /in/LgplG on line 5 Warning: strtolower() expects exactly 1 parameter, 2 given in /in/LgplG on line 5 Warning: strtolower() expects exactly 1 parameter, 2 given in /in/LgplG on line 5 Warning: Invalid operand type was used: array_combine expects arrays or collections in /in/LgplG on line 5 NULL