3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php echo preg_replace('/[^\s\p{P}]/', "", "Olá, mundo!");
Output for 5.2.10 - 5.6.28, hhvm-3.12.0, 7.0.0 - 7.1.0
�, !
Output for hhvm-3.10.0

Process exited with code 153.
Output for 4.4.0 - 4.4.9, 5.0.5 - 5.2.9
, !
Output for 4.3.11, 5.0.0 - 5.0.4
Warning: preg_replace(): Compilation failed: PCRE does not support \L, \l, \N, \P, \p, \U, \u, or \X at offset 5 in /in/LIL71 on line 3
Output for 4.3.0 - 4.3.10
Warning: Compilation failed: PCRE does not support \L, \l, \N, \P, \p, \U, \u, or \X at offset 5 in /in/LIL71 on line 3