3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php declare(ticks=1); declare(allow_override_builtins=1); var_dump(phpversion());
Output for 7.1.0
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "7.1.0"
Output for 7.0.14
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "7.0.14"
Output for 7.0.7
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "7.0.7"
Output for 7.0.6
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "7.0.6"
Output for 7.0.5
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "7.0.5"
Output for 7.0.4
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "7.0.4"
Output for 7.0.3
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "7.0.3"
Output for 7.0.2
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "7.0.2"
Output for 7.0.1
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "7.0.1"
Output for 7.0.0
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "7.0.0"
Output for hhvm-3.10.0 - 3.12.0
string(11) "5.6.99-hhvm"
Output for 5.6.28
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.28"
Output for 5.6.22
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.22"
Output for 5.6.21
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.21"
Output for 5.6.20
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.20"
Output for 5.6.19
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.19"
Output for 5.6.18
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.18"
Output for 5.6.17
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.17"
Output for 5.6.16
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.16"
Output for 5.6.15
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.15"
Output for 5.6.14
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.14"
Output for 5.6.13
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.13"
Output for 5.6.12
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.12"
Output for 5.6.11
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.11"
Output for 5.6.10
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.6.10"
Output for 5.6.9
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.9"
Output for 5.6.8
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.8"
Output for 5.6.7
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.7"
Output for 5.6.6
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.6"
Output for 5.6.5
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.5"
Output for 5.6.4
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.4"
Output for 5.6.3
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.3"
Output for 5.6.2
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.2"
Output for 5.6.1
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.1"
Output for 5.6.0
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.6.0"
Output for 5.5.36
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.36"
Output for 5.5.35
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.35"
Output for 5.5.34
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.34"
Output for 5.5.33
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.33"
Output for 5.5.32
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.32"
Output for 5.5.31
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.31"
Output for 5.5.30
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.30"
Output for 5.5.29
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.29"
Output for 5.5.28
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.28"
Output for 5.5.27
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.27"
Output for 5.5.26
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.26"
Output for 5.5.25
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.25"
Output for 5.5.24
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.24"
Output for 5.5.23
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.23"
Output for 5.5.22
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.22"
Output for 5.5.21
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.21"
Output for 5.5.20
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.20"
Output for 5.5.19
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.19"
Output for 5.5.18
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.18"
Output for 5.5.16
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.16"
Output for 5.5.15
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.15"
Output for 5.5.14
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.14"
Output for 5.5.13
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.13"
Output for 5.5.12
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.12"
Output for 5.5.11
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.11"
Output for 5.5.10
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.5.10"
Output for 5.5.9
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.9"
Output for 5.5.8
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.8"
Output for 5.5.7
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.7"
Output for 5.5.6
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.6"
Output for 5.5.5
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.5"
Output for 5.5.4
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.4"
Output for 5.5.3
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.3"
Output for 5.5.2
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.2"
Output for 5.5.1
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.1"
Output for 5.5.0
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.5.0"
Output for 5.4.45
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.45"
Output for 5.4.44
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.44"
Output for 5.4.43
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.43"
Output for 5.4.42
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.42"
Output for 5.4.41
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.41"
Output for 5.4.40
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.40"
Output for 5.4.39
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.39"
Output for 5.4.38
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.38"
Output for 5.4.37
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.37"
Output for 5.4.36
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.36"
Output for 5.4.35
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.35"
Output for 5.4.34
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.34"
Output for 5.4.32
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.32"
Output for 5.4.31
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.31"
Output for 5.4.30
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.30"
Output for 5.4.29
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.29"
Output for 5.4.28
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.28"
Output for 5.4.27
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.27"
Output for 5.4.26
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.26"
Output for 5.4.25
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.25"
Output for 5.4.24
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.24"
Output for 5.4.23
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.23"
Output for 5.4.22
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.22"
Output for 5.4.21
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.21"
Output for 5.4.20
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.20"
Output for 5.4.19
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.19"
Output for 5.4.18
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.18"
Output for 5.4.17
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.17"
Output for 5.4.16
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.16"
Output for 5.4.15
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.15"
Output for 5.4.14
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.14"
Output for 5.4.13
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.13"
Output for 5.4.12
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.12"
Output for 5.4.11
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.11"
Output for 5.4.10
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.4.10"
Output for 5.4.9
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.9"
Output for 5.4.8
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.8"
Output for 5.4.7
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.7"
Output for 5.4.6
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.6"
Output for 5.4.5
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.5"
Output for 5.4.4
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.4"
Output for 5.4.3
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.3"
Output for 5.4.2
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.2"
Output for 5.4.1
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.1"
Output for 5.4.0
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.4.0"
Output for 5.3.29
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.29"
Output for 5.3.28
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.28"
Output for 5.3.27
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.27"
Output for 5.3.26
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.26"
Output for 5.3.25
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.25"
Output for 5.3.24
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.24"
Output for 5.3.23
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.23"
Output for 5.3.22
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.22"
Output for 5.3.21
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.21"
Output for 5.3.20
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.20"
Output for 5.3.19
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.19"
Output for 5.3.18
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.18"
Output for 5.3.17
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.17"
Output for 5.3.16
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.16"
Output for 5.3.15
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.15"
Output for 5.3.14
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.14"
Output for 5.3.13
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.13"
Output for 5.3.12
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.12"
Output for 5.3.11
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.11"
Output for 5.3.10
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(6) "5.3.10"
Output for 5.3.9
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.9"
Output for 5.3.8
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.8"
Output for 5.3.7
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.7"
Output for 5.3.6
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.6"
Output for 5.3.5
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.5"
Output for 5.3.4
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.4"
Output for 5.3.3
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.3"
Output for 5.3.2
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.2"
Output for 5.3.1
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.1"
Output for 5.3.0
Warning: Unsupported declare 'allow_override_builtins' in /in/HPPGr on line 5 string(5) "5.3.0"
Output for 5.2.17
string(6) "5.2.17"
Output for 5.2.16
string(6) "5.2.16"
Output for 5.2.15
string(6) "5.2.15"
Output for 5.2.14
string(6) "5.2.14"
Output for 5.2.13
string(6) "5.2.13"
Output for 5.2.12
string(6) "5.2.12"
Output for 5.2.11
string(6) "5.2.11"
Output for 5.2.10
string(6) "5.2.10"
Output for 5.2.9
string(5) "5.2.9"
Output for 5.2.8
string(5) "5.2.8"
Output for 5.2.7
string(5) "5.2.7"
Output for 5.2.6
string(5) "5.2.6"
Output for 5.2.5
string(5) "5.2.5"
Output for 5.2.4
string(5) "5.2.4"
Output for 5.2.3
string(5) "5.2.3"
Output for 5.2.2
string(5) "5.2.2"
Output for 5.2.1
string(5) "5.2.1"
Output for 5.2.0
string(5) "5.2.0"
Output for 5.1.6
string(5) "5.1.6"
Output for 5.1.5
string(5) "5.1.5"
Output for 5.1.4
string(5) "5.1.4"
Output for 5.1.3
string(5) "5.1.3"
Output for 5.1.2
string(5) "5.1.2"
Output for 5.1.1
string(5) "5.1.1"
Output for 5.1.0
string(5) "5.1.0"
Output for 5.0.5
string(5) "5.0.5"
Output for 5.0.4
string(5) "5.0.4"
Output for 5.0.3
string(5) "5.0.3"
Output for 5.0.2
string(5) "5.0.2"
Output for 5.0.1
string(5) "5.0.1"
Output for 5.0.0
string(5) "5.0.0"
Output for 4.4.9
string(5) "4.4.9"
Output for 4.4.8
string(5) "4.4.8"
Output for 4.4.7
string(5) "4.4.7"
Output for 4.4.6
string(5) "4.4.6"
Output for 4.4.5
string(5) "4.4.5"
Output for 4.4.4
string(5) "4.4.4"
Output for 4.4.3
string(5) "4.4.3"
Output for 4.4.2
string(5) "4.4.2"
Output for 4.4.1
string(5) "4.4.1"
Output for 4.4.0
string(5) "4.4.0"
Output for 4.3.11
string(6) "4.3.11"
Output for 4.3.10
string(6) "4.3.10"
Output for 4.3.9
string(5) "4.3.9"
Output for 4.3.8
string(5) "4.3.8"
Output for 4.3.7
string(5) "4.3.7"
Output for 4.3.6
string(5) "4.3.6"
Output for 4.3.5
string(5) "4.3.5"
Output for 4.3.4
string(5) "4.3.4"
Output for 4.3.3
string(5) "4.3.3"
Output for 4.3.2
string(5) "4.3.2"
Output for 4.3.1
string(5) "4.3.1"
Output for 4.3.0
string(5) "4.3.0"