3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php if (version_compare(PHP_VERSION, '5.4.0') === -1) { echo 'This version of ownCloud requires at least PHP 5.4.0'.PHP_EOL; echo 'You are currently running ' . PHP_VERSION . '. Please update your PHP version.'.PHP_EOL; return; }
Output for 5.4.0 - 7.2.0
Output for 5.3.29
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.29. Please update your PHP version.
Output for 5.3.28
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.28. Please update your PHP version.
Output for 5.3.27
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.27. Please update your PHP version.
Output for 5.3.26
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.26. Please update your PHP version.
Output for 5.3.25
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.25. Please update your PHP version.
Output for 5.3.24
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.24. Please update your PHP version.
Output for 5.3.23
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.23. Please update your PHP version.
Output for 5.3.22
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.22. Please update your PHP version.
Output for 5.3.21
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.21. Please update your PHP version.
Output for 5.3.20
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.20. Please update your PHP version.
Output for 5.3.19
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.19. Please update your PHP version.
Output for 5.3.18
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.18. Please update your PHP version.
Output for 5.3.17
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.17. Please update your PHP version.
Output for 5.3.16
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.16. Please update your PHP version.
Output for 5.3.15
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.15. Please update your PHP version.
Output for 5.3.14
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.14. Please update your PHP version.
Output for 5.3.13
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.13. Please update your PHP version.
Output for 5.3.12
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.12. Please update your PHP version.
Output for 5.3.11
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.11. Please update your PHP version.
Output for 5.3.10
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.10. Please update your PHP version.
Output for 5.3.9
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.9. Please update your PHP version.
Output for 5.3.8
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.8. Please update your PHP version.
Output for 5.3.7
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.7. Please update your PHP version.
Output for 5.3.6
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.6. Please update your PHP version.
Output for 5.3.5
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.5. Please update your PHP version.
Output for 5.3.4
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.4. Please update your PHP version.
Output for 5.3.3
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.3. Please update your PHP version.
Output for 5.3.2
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.2. Please update your PHP version.
Output for 5.3.1
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.1. Please update your PHP version.
Output for 5.3.0
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.3.0. Please update your PHP version.
Output for 5.2.17
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.17. Please update your PHP version.
Output for 5.2.16
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.16. Please update your PHP version.
Output for 5.2.15
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.15. Please update your PHP version.
Output for 5.2.14
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.14. Please update your PHP version.
Output for 5.2.13
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.13. Please update your PHP version.
Output for 5.2.12
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.12. Please update your PHP version.
Output for 5.2.11
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.11. Please update your PHP version.
Output for 5.2.10
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.10. Please update your PHP version.
Output for 5.2.9
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.9. Please update your PHP version.
Output for 5.2.8
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.8. Please update your PHP version.
Output for 5.2.7
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.7. Please update your PHP version.
Output for 5.2.6
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.6. Please update your PHP version.
Output for 5.2.5
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.5. Please update your PHP version.
Output for 5.2.4
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.4. Please update your PHP version.
Output for 5.2.3
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.3. Please update your PHP version.
Output for 5.2.2
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.2. Please update your PHP version.
Output for 5.2.1
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.1. Please update your PHP version.
Output for 5.2.0
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.2.0. Please update your PHP version.
Output for 5.1.6
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.1.6. Please update your PHP version.
Output for 5.1.5
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.1.5. Please update your PHP version.
Output for 5.1.4
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.1.4. Please update your PHP version.
Output for 5.1.3
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.1.3. Please update your PHP version.
Output for 5.1.2
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.1.2. Please update your PHP version.
Output for 5.1.1
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.1.1. Please update your PHP version.
Output for 5.1.0
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.1.0. Please update your PHP version.
Output for 5.0.5
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.0.5. Please update your PHP version.
Output for 5.0.4
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.0.4. Please update your PHP version.
Output for 5.0.3
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.0.3. Please update your PHP version.
Output for 5.0.2
This version of ownCloud requires at least PHP 5.4.0 You are currently running 5.0.2. Please update your PHP version.
Output for 5.0.1
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 5.0.1. Please update your PHP version.PHP_EOL
Output for 5.0.0
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 5.0.0. Please update your PHP version.PHP_EOL
Output for 4.4.9
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.9. Please update your PHP version.
Output for 4.4.8
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.8. Please update your PHP version.
Output for 4.4.7
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.7. Please update your PHP version.
Output for 4.4.6
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.6. Please update your PHP version.
Output for 4.4.5
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.5. Please update your PHP version.
Output for 4.4.4
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.4. Please update your PHP version.
Output for 4.4.3
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.3. Please update your PHP version.
Output for 4.4.2
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.2. Please update your PHP version.
Output for 4.4.1
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.1. Please update your PHP version.
Output for 4.4.0
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.4.0. Please update your PHP version.
Output for 4.3.11
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.3.11. Please update your PHP version.
Output for 4.3.10
This version of ownCloud requires at least PHP 5.4.0 You are currently running 4.3.10. Please update your PHP version.
Output for 4.3.9
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.9. Please update your PHP version.PHP_EOL
Output for 4.3.8
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.8. Please update your PHP version.PHP_EOL
Output for 4.3.7
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.7. Please update your PHP version.PHP_EOL
Output for 4.3.6
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.6. Please update your PHP version.PHP_EOL
Output for 4.3.5
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.5. Please update your PHP version.PHP_EOL
Output for 4.3.4
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.4. Please update your PHP version.PHP_EOL
Output for 4.3.3
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.3. Please update your PHP version.PHP_EOL
Output for 4.3.2
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.2. Please update your PHP version.PHP_EOL
Output for 4.3.1
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.1. Please update your PHP version.PHP_EOL
Output for 4.3.0
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 4 This version of ownCloud requires at least PHP 5.4.0PHP_EOL Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/AFLRi on line 5 You are currently running 4.3.0. Please update your PHP version.PHP_EOL