3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php class Foo { public function setBar(Bar $bar) {} } class Baz extends Foo { public function setBar(Tab $bar) {} }
based on UpqJe
Output for 7.0.0 - 7.2.0
Warning: Declaration of Baz::setBar(Tab $bar) should be compatible with Foo::setBar(Bar $bar) in /in/1rL7X on line 11
Output for 5.4.0 - 5.6.28
Strict Standards: Declaration of Baz::setBar() should be compatible with Foo::setBar(Bar $bar) in /in/1rL7X on line 11
Output for 5.3.19 - 5.3.29
Strict Standards: Declaration of Baz::setBar() should be compatible with that of Foo::setBar() in /in/1rL7X on line 11