3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $str = "Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586)"; echo preg_match($str, ';');
Output for 4.3.11 - 5.6.28, 7.0.0 - 7.1.0
Warning: preg_match(): Delimiter must not be alphanumeric or backslash in /in/0acB2 on line 5
Output for 4.3.0 - 4.3.10, hhvm-3.10.0 - 3.12.0
Warning: Delimiter must not be alphanumeric or backslash in /in/0acB2 on line 5